[time-nuts] GPS, NTP, and Cisco routers...

Bob Chan chanarbob at gmail.com
Fri Dec 5 19:51:51 EST 2014


Dear all,

Do any one still using Cisco 7200 as NTP master? and get ref clock from
Microsemi GPS TOD via Aux port

I used to have a TimeSource3600 to feed TOD to a Cisco7204VXR, but the
TS3600 was dead, and I TimeSource3550 was installed.

But I found the 7204 cannot get a reliable PPS from the TS3550.

In 7204, I use below command:
line aux 0
 ntp refclock telecom-solutions pps cts stratum 0
 no exec
 transport input all
 stopbits 1
line vty 0 4
 exec-timeout 20 0
!
ntp access-group query-only 95
ntp access-group peer 96
ntp access-group serve 97
ntp access-group serve-only 98
ntp master

In TS3550, I set the TOD format to Cisco, and a TOD converter was installed.

The 7204 can sync to GPS after a reboot. but after some time (form min. to
an hour) it will lost sync to GPS and said "Bad Time" or "No PPS signal" in
sh ntp asso detail" and sh line aux wil indicate alot of "noise" & "overrun"

==== 7204 ====
sh ntp ass de
127.127.7.1 configured, our_master, sane, valid, stratum 7
ref ID 127.127.7.1, time D8212701.14C20B50 (12:28:49.081 HKT Thu Nov 27
2014)
our mode active, peer mode passive, our poll intvl 64, peer poll intvl 64
root delay 0.00 msec, root disp 0.00, reach 377, sync dist 0.015
delay 0.00 msec, offset 0.0000 msec, dispersion 0.02
precision 2**18, version 3
org time D8212701.14C20B50 (12:28:49.081 HKT Thu Nov 27 2014)
rcv time D8212701.14C20B50 (12:28:49.081 HKT Thu Nov 27 2014)
xmt time D8212701.14C1C10F (12:28:49.081 HKT Thu Nov 27 2014)
filtdelay =     0.00    0.00    0.00    0.00    0.00    0.00    0.00    0.00
filtoffset =    0.00    0.00    0.00    0.00    0.00    0.00    0.00    0.00
filterror =     0.02    0.99    1.97    2.94    3.92    4.90    5.87    6.85
Reference clock status:  Running normally
Timecode:

 --More--         127.127.6.1 configured, insane, invalid, unsynced,
stratum 0
ref ID .GPS., time 00000000.00000000 (08:00:00.000 HKT Mon Jan 1 1900)
our mode active, peer mode unspec, our poll intvl 64, peer poll intvl 64
root delay 0.00 msec, root disp 0.00, reach 0, sync dist 103.516
delay 0.00 msec, offset 0.0000 msec, dispersion 16000.00
precision 2**20, version 3
org time 00000000.00000000 (08:00:00.000 HKT Mon Jan 1 1900)
rcv time 00000000.00000000 (08:00:00.000 HKT Mon Jan 1 1900)
xmt time D8212733.14C1CF13 (12:29:39.081 HKT Thu Nov 27 2014)
filtdelay =     0.00    0.00    0.00    0.00    0.00    0.00    0.00    0.00
filtoffset =    0.00    0.00    0.00    0.00    0.00    0.00    0.00    0.00
filterror =  16000.0 16000.0 16000.0 16000.0 16000.0 16000.0 16000.0 16000.0
Reference clock status:  No PPS signal
Timecode: *,A,56989,14/11/27,04:29:47,+00.0,0,22N22.238,114E07.820,+0095

sh lin aux 0
   Tty Typ     Tx/Rx    A Modem  Roty AccO AccI   Uses   Noise  Overruns
Int
*    1 AUX   9600/9600  -    -      -    -    -      0     581     1/799854
  -

Line 1, Location: "", Type: ""
Length: 24 lines, Width: 80 columns
Baud rate (TX/RX) is 9600/9600, no parity, 1 stopbits, 8 databits
Status: Ready, Active, Modem Signals Polled
Capabilities: EXEC Suppressed, NTP Reference Clock, PPS Reference Clock
Modem state: Ready
Modem hardware state: CTS* noDSR  DTR RTS
Special Chars: Escape  Hold  Stop  Start  Disconnect  Activation
                ^^x    none   -     -       none
Timeouts:      Idle EXEC    Idle Session   Modem Answer  Session   Dispatch
               00:10:00        never                        none     not set
                            Idle Session Disconnect Warning
                              never
                            Login-sequence User Response
                             00:00:30
                            Autoselect Initial Wait
                              not set
Modem type is unknown.
Session limit is not set.
Time since activation: never
Editing is enabled.
History is enabled, history size is 10.
DNS resolution in show commands is enabled
Full user help is disabled
Allowed input transports are pad v120 telnet.
Allowed output transports are pad v120 telnet.
Preferred transport is telnet.
No output characters are padded
No special data dispatching characters
==== End ====

I had replace the 7204, reboot the TS3550, replace TOD converter and
related cable.but no luck. Any idea?

Dear Mark Allwright, Can I have your "Application Note 600"?

Thanks in advance for any suggestion.

Best Reg.

Bob



More information about the time-nuts mailing list