[time-nuts] Beginner question - unexpected possible jitter in 1 PPS output of Motorola ONCORE UT+ module

Jean-Louis Oneto jl.oneto at free.fr
Sat May 31 22:58:11 EDT 2014


Hello,
The UT_Eng_Notes file I have (for the UT, not the UT+) specify:

    1PPS Signal Description
    . 0 to 5 V pulse
    . Pulse accuracy:
    - Normal mode: < 130 ns (one sigma) with SA on
    - Position-hold mode: < 50 ns (one sigma) with SA on
    . Rise time from 0 to 5 V is approximately 20 to 30 ns with a
    recommended maximum line loading
    of 50 pF
    . 1PPS time mark is synchronous with rising edge of pulse
    . Pulse width is approximately 200 ms (*± 1 ms*), i.e. the falling
    edge occurs approximately 200 ms
    after the rising edge
    . Pulse can be advanced to account for antenna cable delay using the
    1PPS Cable Delay command
    . Pulse location can be delayed using the 1PPS Offset command to
    position the pulse at any desired
    time within the one second window


So if your divider is clocked on the falling edge of the 1PPS, you can 
expect a 1 ms jitter...
Regards,
Jean-Louis

On 31/05/2014 22:02, David Feldman wrote:
> Picked this project back up this afternoon after couple of weeks, narrowed the problem down but not solved.
>
> Refresh: My ONCORE UT+ module appears to have very extreme jitter (on on order of 100 uSec, not nSec random variation between leading edges of successive pulses) in the 1 PPS output. I am using the 1 Hz signal, divided to 0.05 Hz at 50% duty cycle (10 seconds high, 10 seconds low), to gate my frequency counter's reference oscillator back into the same counter running in pulse-count mode so I can adjust the OCXO bias on the counter for calibration. 10 seconds count-up, followed by 10 seconds idle where I can record the measurement, reset the counter, and adjust the OCXO bias.
>
> I've now built a simple 1 Hz pulse generator using a 32768 Hz crystal and CD4060 divider. Using that signal instead of the ONCORE UT+, my counter is behaving as expected (that is, each count-up session results in the same result, +/- a few counts as would be expected with a simple 1 PPS signal.) This tells me the gating circuit and interface to the counter's reference output and count input are probably OK.
>
> When using the ONCORE UT+, the counts vary by 10000 or more from one 10-second capture to the next (each count-up period would total 130,000,000 counts if the ONCORE UT+ was working properly and the reference OCXO was properly adjusted.)
>
> I am not yet able to determine why the UT+ 1 PPS signal has such severe jitter. TAC software tells me 7-8 satellites acquired/tracked once cold start has completed (10-15 minutes.) Is there something I'm missing about UT+ care and feeding? There are no RF or switching digital signals close to the UT+ module (the gating circuit is a couple of inches away, both mounted on the same perf board, with common ground and power supply connections.
>
> Now that I've ruled out the counter/gating circuit interface, I begin to suspect the UT+ but don't really know what to expect in terms of normal/abnormal operation.
>
> Any advice at this point?
>
> Thanks,
>
> Dave
>
> _______________________________________________
> time-nuts mailing list -- time-nuts at febo.com
> To unsubscribe, go to https://www.febo.com/cgi-bin/mailman/listinfo/time-nuts
> and follow the instructions there.
>




More information about the time-nuts mailing list