[time-nuts] 58503A alarm light on, but :SYSTEM:STATUS? indicates all is ok

Dr. David Kirkby (Kirkby Microwave Ltd) drkirkby at kirkbymicrowave.co.uk
Wed Apr 1 05:05:20 EDT 2015


Yesterday (31st March 2015) the "GPS lock" light of my 58503A went out
and the "Holdover" light came on. The Alarm LED was *not* on. It had
been like this for an hour or more. I removed the N connector, could
see there was 5V DC on the antenna, and a visual inspection of the
antenna cable did not give me any cause for concerns.  I decided to
power cycle it. Anyway, it came back up, quickly achieved lock, and
I'd rather hoped it was just a glitch, and that was the end of it. NO
SUCH LUCK!

Today I notice the GPS lock light is on, Holdover is off, but the
alarm LED is on. This is quite a different set of LEDs to yesterday.

This time I connected the GPS receiver to a computer, to try to find
out what was up, and are confused in that the status appears to be ok,
yet the alarm is on. The log does not indicate why the alarm light
should be on. (I have had it come on before, immediately after power
up, when it indicated the power supplies were out of regulation,
although I've never managed to observe this on a peak holding DVM, so
I am not convinced the power supply was the cause.) But the unit has
been stable for quite a while, yet the alarm is on, but nothing in the
log indicates a problem.

scpi > :SYSTEM:STATUS?
------------------------------- Receiver Status -------------------------------

SYNCHRONIZATION ............................................. [ Outputs Valid ]
SmartClock Mode ___________________________   Reference Outputs _______________
>> Locked to GPS                              TFOM     3             FFOM     0
   Recovery                                   1PPS TI +5.0 ns relative to GPS
   Holdover                                   HOLD THR 1.000 us
   Power-up                                   Holdover Uncertainty ____________
                                              Predict  4.9 us/initial 24 hrs

ACQUISITION ................................................ [ GPS 1PPS Valid ]
Tracking: 6 ____   Not Tracking: 4 ________   Time ____________________________
PRN  El  Az   SS   PRN  El  Az                UTC      08:19:28     01 Apr 2015
  2  46 281   69     5  17 294                GPS 1PPS Synchronized to UTC
  6  45 207   56    16  14  58                ANT DLY  0 ns
  7  50 150   59    23  33  68                Position ________________________
  9  65  67   75    30  25 177                MODE     Hold
 10  81 277   63
 20  58 289   62                              LAT      N  51:39:04.143
                                              LON      E   0:46:36.402
ELEV MASK 10 deg                              HGT               +47.15 m  (MSL)
HEALTH MONITOR ......................................................... [ OK ]
Self Test: OK    Int Pwr: OK   Oven Pwr: OK   OCXO: OK   EFC: OK   GPS Rcv: OK


The "HEALTH MONITOR" seems to say it is ok, but the alarm LED is on.
Querying the alarm LED, does indicate it is on.

scpi > :LED:ALARM?
1

So I decided to check the current date and time (which seem
"reasonable"), and the log.

scpi > :PTIME:DATE?
+2015,+4,+1
scpi > :PTIME:TIME?
+8,+59,+52
scpi >  :DIAG:LOG:READ:ALL?
Log status: 106 entries

Log 001:20141215.00:00:00:  Log cleared
Log 002:20141215.00:00:00:  System preset
Log 003:20141215.00:01:41:  GPS reference valid at 20141215.18:27:04
Log 004:20141215.18:28:12:  GPS lock started
Log 005:20141215.20:26:57:  Position hold mode started
Log 006:20141218.00:00:00:  Power on
Log 007:20141218.00:03:57:  GPS reference valid at 20141218.23:25:08
Log 008:20141218.23:30:09:  GPS lock started
Log 009:20141219.01:24:46:  Position hold mode started
Log 010:20141227.00:00:00:  Power on
Log 011:20141227.00:08:16:  GPS reference valid at 20141227.19:23:09
Log 012:20141227.19:24:17:  GPS lock started
Log 013:20141227.21:23:19:  Position hold mode started
Log 014:20141229.00:00:00:  Power on
Log 015:20141229.00:04:13:  GPS reference valid at 20141230.19:54:39
Log 016:20141230.19:58:58:  GPS lock started
Log 017:20141230.21:54:54:  Position hold mode started
Log 018:20150101.00:00:00:  Power on
Log 019:20150101.00:00:00:  Power on
Log 020:20150101.00:00:00:  Power on
Log 021:20150101.00:00:11:  5V is out of tolerance, value: 5.52
Log 022:20150101.00:00:11:  15V is out of tolerance, value: 19.46
Log 023:20150101.00:00:00:  Power on
Log 024:20150101.00:04:09:  GPS reference valid at 20150101.11:38:39
Log 025:20150101.11:39:46:  GPS lock started
Log 026:20150101.13:30:40:  GPS reference valid at 20150101.13:30:39
Log 027:20150101.13:31:47:  GPS lock started
Log 028:20150101.13:39:40:  Position hold mode started
Log 029:20150101.00:00:00:  Power on
Log 030:20150101.00:00:55:  Power on
Log 031:20150101.00:00:55:  Power on
Log 032:20150101.00:00:00:  Power on
Log 033:20150101.00:00:00:  Power on
Log 034:20150101.00:00:08:  Power on
Log 035:20150101.00:00:09:  Power on
Log 036:20150101.00:00:16:  Power on
Log 037:20150101.00:00:27:  Power on
Log 038:20150101.00:00:30:  Power on
Log 039:20150101.00:00:47:  Power on
Log 040:20150101.00:00:53:  Power on
Log 041:20150101.00:00:00:  Power on
Log 042:20150101.00:00:07:  Power on
Log 043:20150101.00:00:00:  Power on
Log 044:20150101.00:00:11:  Power on
Log 045:20150101.00:00:00:  Power on
Log 046:20150101.00:00:00:  Power on
Log 047:20150101.00:00:00:  Power on
Log 048:20150101.00:00:00:  Power on
Log 049:20150101.00:00:04:  Power on
Log 050:20150101.00:00:09:  Power on
Log 051:20150101.00:00:13:  Power on
Log 052:20150101.00:00:20:  Power on
Log 053:20150101.00:00:00:  Power on
Log 054:20150101.00:00:00:  Power on
Log 055:20150101.00:00:00:  Power on
Log 056:20150101.00:00:00:  Power on
Log 057:20150101.00:00:00:  Power on
Log 058:20150101.00:00:19:  Power on
Log 059:20150101.00:00:28:  Power on
Log 060:20150101.00:00:32:  Power on
Log 061:20150101.00:00:39:  Power on
Log 062:20150101.00:00:00:  Power on
Log 063:20150101.00:00:05:  Power on
Log 064:20150101.00:01:34:  Power on
Log 065:20150101.00:00:00:  Power on
Log 066:20150101.00:00:00:  Power on
Log 067:20150101.00:00:11:  5V is out of tolerance, value: 5.52
Log 068:20150101.00:00:11:  15V is out of tolerance, value: 19.46
Log 069:20150101.00:00:00:  Power on
Log 070:20150101.00:03:51:  GPS reference valid at 20150101.20:01:38
Log 071:20150101.20:02:45:  GPS lock started
Log 072:20150101.22:01:35:  Position hold mode started
Log 073:20150103.00:00:00:  Power on
Log 074:20150103.00:00:00:  Power on
Log 075:20150103.00:00:00:  Power on
Log 076:20150103.00:05:29:  GPS reference valid at 20150103.15:56:09
Log 077:20150103.15:57:17:  GPS lock started
Log 078:20150103.17:57:19:  Position hold mode started
Log 079:20150109.17:46:10:  Power on
Log 080:20150109.17:50:58:  GPS reference valid at 20150109.17:51:02
Log 081:20150109.17:52:10:  GPS lock started
Log 082:20150109.18:13:01:  Power on
Log 083:20150109.18:14:03:  Power on
Log 084:20150109.00:00:00:  Power on
Log 085:20150109.00:04:16:  GPS reference valid at 20150109.18:43:08
Log 086:20150109.18:44:16:  GPS lock started
Log 087:20150109.20:42:37:  Position hold mode started
Log 088:20150311.00:00:00:  Power on
Log 089:20150311.00:08:00:  GPS reference valid at 20150311.13:23:08
Log 090:20150311.13:24:16:  GPS lock started
Log 091:20150311.15:22:37:  Position hold mode started
Log 092:20150330.19:30:37:  Holdover started, not tracking GPS
Log 093:20150330.20:11:35:  GPS lock started
Log 094:20150330.21:44:00:  Holdover started, not tracking GPS
Log 095:20150330.21:46:18:  GPS lock started
Log 096:20150331.12:18:13:  Holdover started, not tracking GPS
Log 097:20150331.12:32:41:  GPS lock started
Log 098:20150331.12:42:42:  Holdover started, not tracking GPS
Log 099:20150331.12:47:30:  GPS lock started
Log 100:20150331.13:41:30:  Holdover started, not tracking GPS
Log 101:20150331.14:21:58:  GPS lock started
Log 102:20150331.14:35:23:  Holdover started, GPS
Log 103:20150331.00:00:00:  Power on
Log 104:20150331.00:08:19:  GPS reference valid at 20150331.15:02:08
Log 105:20150331.15:03:16:  GPS lock started
Log 106:20150331.17:01:37:  Position hold mode started

I'm not sure why there were a bunch of "Power on" entries (029-066),
but some of the log entries (e.g. 061 to 066) do not appear to be in
chronological order. Other more recent "Power on" entries could be due
to mains failure, as this is not on a UPS, and I know there have been
some power outages. I was not aware of any outages yesterday - if they
were, they were too short to cause any computers to reboot.

Any suggestions what I can do to try to find why the alarm would be on?

Once the LED is on, do they ever go out? I assume its purpose is to
indicate there was a problem, rather than that there's currently a
problem, but I'm puzzled there's no entry in the log to indicate why
the alarm is on

Dr. David Kirkby Ph.D CEng MIET
Kirkby Microwave Ltd
Registered office: Stokes Hall Lodge, Burnham Rd, Althorne, Essex, CM3 6DT, UK.
Registered in England and Wales, company number 08914892.
http://www.kirkbymicrowave.co.uk/
Tel: 07910 441670 / +44 7910 441670 (0900 to 2100 GMT only please)



More information about the time-nuts mailing list