[time-nuts] HP 5372A advice

Magnus Danielson magnus at rubidium.dyndns.org
Wed Jan 20 00:32:24 EST 2016


Hi Morris,

On 01/20/2016 03:48 AM, Morris Odell wrote:
> Hi all,
>
> I recently was fortunate enough to obtain one of these amazing
> instruments but regrettable no copy of the main operating manual. I find
> myself a bit puzzled by some of it's behaviour.

I strongly advice you to download the manuals. It is an instrument that 
is puzzling at times, so the manuals are needed. The upside is that they 
are really interesting. The operators and programming manuals get you 
understand what it really does. You also want the service manual.
Anyway, last time I looked I could download them from Agilent/Keysight.

> The unit is clean and passes all the self-tests. When I first got it it
> seemed to work very nicely looking at my in-house 10 MHz frequency
> standard which is a Z3815 GPSDO. It needed a new memory back up battery
> and once I replaced it I tried to do the input sensitivity recalibration
> procedure that's required. That procedure  requires the application of a
> 10 KHz 60 mv p-p sine wave and that's when I ran into trouble.

Been there, done that, was relatively painless.

> I have found that if I and try to look at low frequency signals with the
> 5372A they appear to have enormous levels of variation and appear quite
> erratic. The histogram display just shows peaks all over the place. I
> have tried with 10 KHz from a 3325B and 100 KHz from a 8656B both of
> which use the GPSDO as a reference and they both show enormous
> variation. It's the same whether I use the GPSDO as a ref for the 5372A
> or it's own internal ref.  If I apply 10 MHz and above from either of
> the two generators all looks well but there are occasional glitches.
> Using the A or B inputs or swapping input pods makes no difference. With
> VHF and UHF frequencies up to the 990 MHz limit of the 8656B it seems to
> work perfectly using the C channel of the 5372B.
>
> I thought it might have been something to do with the synthesized nature
> of the 3325 and 8656 so I warmed up the old faithful 200CD at 10 KHz and
> it didn't make any difference although the 200CD would never be as
> stable as a more modern synthesized source locked to the GPS. I haven't
> tried it yet with anything higher in frequency although I do have a 2
> GHz non-synthesized generator I could set up.
>
> What's going on here? Any ideas? Do I need to change any of the input,
> trigger or arming settings? So far nothing I have tried in the way of
> changing settings makes any difference.

Trigger jitter. More importantly, now you see it!

The trigger jitter follows the formula:

t_jitter = e_n / S

e_n is the noise voltage RMS value
S is the slew-rate
t_jitter is the trigger jitter RMS value

Slew-rate depends for sine signals on the amplitude and frequency:

S = 2*pi*f*A_peak = sqrt(2)*pi*f*A_rms

where f is frequency
A_peak is peak amplitude
A_rms is RMS amplitude

In practice, there is some instrument local jitter which adds on top of 
this, which adds as

t_total = sqrt(t_jitter^2 + t_instrument^2)

Anyway. Experiment with amplitude and frequency and see if your jitter 
follow these properties. Try to establish the e_n noise level. Try 
verify it against instrument specifications.

Just could be that this is a learning experience rather than an 
instrument fault, and the only fault of the instrument is that it now 
actually shows you this jitter.

As you accumulate you should get a gaussian distribution.

Cheers,
Magnus



More information about the time-nuts mailing list