[time-nuts] Weird GPSDO behavior - update

Lars Walenius lars.walenius at hotmail.com
Thu Oct 5 13:51:21 EDT 2017


Hello,

If I look on the one hour plot it look like it goes in hold mode due to zero used satellites. If my assumption that the light blue graph in the bottom is satellites it sees no satellites during about a minute and after that it selects a fast time constant. From the TIC offset and DAC changes, a time constant of 10-20 secs seems reasonable if it is a PI-loop with a low pass filter on the TIC value.

So nothing strange except the jump of the DAC value in hold mode. As always you really want to know what the firmware does.

As the satellite constellation is the same every 23h56min I guess it could be zero usable satellites every day at about 8am for several days.

Lars


Från: Skip Withrow<mailto:skip.withrow at gmail.com>
Skickat: den 4 oktober 2017 03:17
Till: time-nuts<mailto:time-nuts at febo.com>
Ämne: [time-nuts] Weird GPSDO behavior - update

Hello Time-Nuts,

Well, I think I know a little more about my GPSDO problem, but
probably have more questions now than before.  Thanks for all the
replies to the first post with thoughts and suggestions.

I first tried restarting Lady Heather and doing a cold boot on the
NTGS50AA (then entering the same disciplining values). Same behavior.

I let it run over the weekend and the same behavior happened on
Saturday and Sunday morning.

So, yesterday (Monday morning) I changed the gain to the gain of the
oscillator (.0072Hz/V), damping to 1.2, and time constant to 900s.  On
the attached PRS10-2 plot you can see that it quickly settled.  This
morning, it looks like all is well from the plot (about an hour before
the furnace kicks in at the right of the plot).  HOWEVER, when the
plot is expanded there is still funny business going on with the DAC
control voltage at the same time of day.  I just think the changed
parameters limit the disturbance.  The expanded plot is the attached
PRS10-1.

At this point I'm beginning to think that the NTGS50AA is the issue,
but there are lots of questions left.

1. There are various version of the NTBW50AA/NTGS50AA GPS/operating
firmware.  Mine is 10.3 and I notice that it has the LH 'ro'
designation (as does the 10.4 version).  The 10.5 version does not
give the LH ro notice.  Maybe it behaves better with the disciplining?
 I will have to give a 10.5 a try.

2. Why does the glitch occur at 8am in the morning?  Will have to try
powering the NTGS50AA up at different times and see it the glitch
moves around.

3. Which disciplining parameters are affected by this glitch and which are not?

4. Have other people seen this same behavior?  Does it happen on
Thunderbolts too?

I'll update again when I have more data.

Regards,
Skip Withrow




More information about the time-nuts mailing list