[time-nuts] TS2100 OCXO Conversion: Command exploration

Philip Jackson timenuts at philipjackson.com
Sat Apr 7 16:08:10 EDT 2018


Thanks for posting your research.

Re. the Lock question.

It's been a while since I last played with a TS2100 given the roll over issue, but IIRC the "lock" LED is an indication that you
have more than a specified number of satellites (four sounds familiar) with a signal reading above a certain threshold.  I don't
think it means oscillator discipline lock.

So if you haven't changed any of the masks that are used to interpret the data coming off the GPS card then I would investigate the
quality of your signal into the receiver.

There's a GPS menu under the TIMING menu that will give you a readout of signal strengths.

What antenna are you using and how long and what type of cable is the downlead?  Does the antenna have a complete view of the sky?
The default masks assume a low angle of acceptance I believe.


-----Original Message-----
From: time-nuts [mailto:time-nuts-bounces at febo.com] On Behalf Of Bruce Lane
Sent: Saturday, April 07, 2018 2:46 PM
To: TimeNuts
Subject: [time-nuts] TS2100 OCXO Conversion: Command exploration

Fellow Time-Tickers,

	I'm still experimenting with conversion of the TS2100 from standard TTL
oscillator to OCXO. More specifically, the OCXO I'm trying is made by
the now-defunct Piezo Crystal Company, Carlyle, PA. It's their model
2900082-47, and from what little I've been able to discover, it seems to
match the large 'U56' pattern in the 2100. It is said to be a direct
replacement for the Trimble-branded 37266, so I'm hoping its EFC voltage
is in the 0-5V range.

	I've made much progress in deciphering the menu structure of the 'root
eng' section, thanks to past posts from Greg Dowd and others. Permit me
to explain, for the benefit of those who may be having trouble making
the 'intuitive leap,' as it were. Please note, everything I'm describing
here is done with a hardware RS232 connection directly to the unit, on
P4 - Serial port B. Comm parameters used were 9600-8-N-1, no flow control.

	Symmetricom, apparently, used single words as commands. Anything
following the first word in a command list, unless clearly called out by
an underscore (as in the command 'eeprom_select') is merely descriptive
commentary for the command itself.

	Here's some examples. We'll start with the command 'root' (minus the
quotes, of course). If you type 'root' and simply hit enter, nothing
appears to happen. However, if you type 'root ?' and hit enter, you get

network /
timing /
serial /
utility /
intrinsic help

	This is indeed the visible 'root' level of the command directory. Note
the valuable (to techies) 'root eng' is hidden. Type that command, add a
question mark at the end, hit enter, and you get this:

start net interface
timing tools /
serial tools /
eeprom tools /
spi tools /
flash tools /
display tools /
memory tools /
intrinsic help

	Type 'root eng eeprom ?' and hit enter, and you get:

ethernet address
board serial number
gain default
filter constant
low filter constant
set eeprom
get eeprom
read serial eeprom
write serial eeprom
tx 16 bits to eeprom
location for image
info value
intrinsic help

	Do you see the pattern? The first word, and only the first word, is the
command and whatever you type after that is what value you want entered
as part of the command. The question mark shows a list of commands
available under whatever section you're in.

	Example: Type 'root eng eeprom gain' and the far left column will show
you what the current gain setting is. Type something like 'root eng
eeprom gain -20' and your gain will be set to -20 and the value stored
in the EEPROM.

	Now, here's the fun part. Remember how I'd originally asked about
changing the D/A value, and I couldn't seem to get the syntax right? As
I recall, other list members have had similar issues.

	Check this out: Type 'root timing utils ?' and hit enter. You get:

tfp data
jam sync
force jam
phase on
adjust time
generator offset
gain adjust
filter constant
low filter constant
diff value
d/a load
leap second utc
reference time
cmp delay
intrinsic help

	Now, try this one: 'root timing utils d/a' and hit enter. Here's what I

D/A value (0x0000 - 0xffff) now:0x178

	Next, I tried: 'root timing utils d/a 0x180' and hit enter. Lo and
behold, when I queried the value again, I got:

D/A value (0x0000 - 0xffff) now:0x180

	So -- That's how to set the D/A constant in the beastie!

	Now, with all this said: I'm still waiting for a 'Lock' indicator on
the front. It's tracking, and the D/A value certainly has changed from
what I had it at last night, but I'm still not getting a lock. Here are
my current numbers:

root timing utils tfp 0 -- returned 0x00f2
root timing utils tfp 6 -- returned KM = 0.9994965
root timing utils tfp 7 -- returned KO = 0.9994965
root timing utils gain -- returned gain now:20 (There seems to be a
difference of opinion as to whether -20 or 20 should be used. At this
point, I'm tempted to just set it to zero and see what happens).

root eng eeprom info -- returned 00000024

	Any thoughts on why I don't have a lock as yet?

	And -- I hope this helps out others. Thanks much!

Bruce Lane, ARS KC7GR
kyrrin (at) bluefeathertech dot com
"Quando Omni Flunkus Moritati" (Red Green)
time-nuts mailing list -- time-nuts at febo.com
To unsubscribe, go to https://www.febo.com/cgi-bin/mailman/listinfo/time-nuts
and follow the instructions there.

More information about the time-nuts mailing list